HSLColor Class
An immutable color defined by Hue, Saturation, and Lightness.
@see here for difference between HSL and HSV
Methods
Name | Description | |
---|---|---|
constructor(hue: number0, saturation: number0, lightness: number0): HSLColor | ||
clone(hue?: number, saturation?: number, lightness?: number): HSLColor | ||
toColorDef(transparency: number0): ColorDef | ||
fromColorDef(val: ColorDef): HSLColor Static |
Properties
Name | Type | Description | |
---|---|---|---|
h Readonly | number | Hue | |
l Readonly | number | Lightness | |
s Readonly | number | Saturation |
Defined in
- core/common/src/HSLColor.ts Line 15
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.