ContourStyle Class
The style settings used by either a minor or major contour.
@see - majorStyle
Methods
Name | Description | |
---|---|---|
clone(changedProps?: Partial<ContourStyleProperties>): ContourStyle | Create a copy of this ContourStyle, identical except for any properties specified by changedProps . |
|
equals(other: ContourStyle): boolean | Returns true if this and other are logically equivalent. |
|
toJSON(): ContourStyleProps | ||
compare(lhs: ContourStyle, rhs: ContourStyle): number Static | Performs ordered comparison of two contour styles. | |
create(props?: Partial<ContourStyleProperties>): ContourStyle Static | Create a new ContourStyle. | |
fromJSON(props?: ContourStyleProps): ContourStyle Static |
Properties
Name | Type | Description | |
---|---|---|---|
color Readonly | RgbColor | The color in which to draw the contour lines. | |
pattern Readonly | LinePixels | The pattern for a major or minor contour line. | |
pixelWidth Readonly | number | The width in screen pixels of the contour lines. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.