AreaPattern.HatchDefLine Class
Single hatch line definition
Implements
Methods
Name | Description | |
---|---|---|
constructor(json: AreaPattern.HatchDefLineProps): AreaPattern.HatchDefLine |
Properties
Name | Type | Description | |
---|---|---|---|
angle | Angle | undefined | Angle of hatch line, 0.0 if undefined | |
dashes | number[] | undefined | Array of gap and dash lengths for creating non-solid hatch lines, max of 20. | |
offset | Point2d | undefined | Offset of successive lines. | |
through | Point2d | undefined | Origin point (relative to placement) the hatch passes through, 0.0,0.0 if undefined |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.