RpcConfiguration Class
A RpcConfiguration specifies how calls on an RPC interface will be marshalled, plus other operating parameters. RpcConfiguration is the base class for specific configurations.
Extended by
Methods
Name | Description | |
---|---|---|
constructor(): RpcConfiguration | ||
assignWithRouting<T extends RpcInterface>(definition: RpcInterfaceDefinition<T>, routing: RpcRoutingToken, configuration: () => RpcConfiguration): void Static | Sets the configuration supplier for an RPC interface class for a given routing. | |
initializeInterfaces(configuration: RpcConfiguration): void Static | Initializes the RPC interfaces managed by the configuration. | |
obtain<T extends RpcConfiguration>(configurationConstructor: () => T): T Static | Obtains the instance of an RPC configuration class. |
Properties
Name | Type | Description | |
---|---|---|---|
developmentMode Static | boolean | Whether development mode is enabled. | |
disableRoutingValidation Static | boolean | Whether frontend checks that are relevant in a cloud-hosted routing scenario are disabled. | |
interfaces Abstract Readonly | () => RpcInterfaceDefinition<RpcInterface>[] | The RPC interfaces managed by the configuration. | |
pendingOperationRetryInterval | number | The target interval (in milliseconds) between connection attempts for pending RPC operation requests. | |
strictMode Static | boolean | Whether strict mode is enabled. | |
throwOnTokenMismatch Static | boolean | Whether to throw an error when the IModelRpcProps in the operation parameter list differs from the token in the URL. | |
transientFaultLimit | number | The maximum number of transient faults permitted before request failure. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.