NormalMapProps Interface
Describes how to apply normal mapping to a surface material.
@see RenderMaterialAssetMapsProps.Normal to define a normal map for a RenderMaterialAssetProps.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
NormalFlags | NormalMapFlags | undefined | Flags controlling how the normal map is applied. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
pattern_angle Inherited | number | undefined | TextureMapProps | Angle in degrees to rotate texture when applying; defaults to 0.0 if undefined |
pattern_constantlod_maxdistanceclamp Inherited | number | undefined | TextureMapProps | The maximum distance (from the eye to the surface) at which to clamp the texture size when pattern_useconstantlod is true. |
pattern_constantlod_mindistanceclamp Inherited | number | undefined | TextureMapProps | The minimum distance (from the eye to the surface) at which to clamp the texture size when pattern_useconstantlod is true. |
pattern_constantlod_offset Inherited | Point2dProps | undefined | TextureMapProps | An offset in world units used to shift the texture when pattern_useconstantlod is true. |
pattern_constantlod_repetitions Inherited | number | undefined | TextureMapProps | The number of times the texture is repeated if pattern_useconstantlod is true. |
pattern_flip Inherited | boolean | undefined | TextureMapProps | If true, flip the pattern map in V; if undefined, defaults to false |
pattern_mapping Inherited | TextureMapping.Mode | undefined | TextureMapProps | Mapping mode to use for the texture application; if undefined, defaults to TextureMapping.Mode.Parametric |
pattern_offset Inherited | Point2dProps | undefined | TextureMapProps | X, Y offset to apply to the pattern map; if undefined, defaults to {0,0} |
pattern_scale Inherited | Point2dProps | undefined | TextureMapProps | X, Y scale to apply to the pattern map; if undefined, defaults to {0,0}, which is almost never useful. |
pattern_scalemode Inherited | TextureMapUnits | undefined | TextureMapProps | Units to use when applying the scaling; if undefined, defaults to Relative |
pattern_u_flip Inherited | boolean | undefined | TextureMapProps | If true, flip the pattern map in U; if undefined, defaults to false |
pattern_useconstantlod Inherited | boolean | undefined | TextureMapProps | If true, override the mapping mode with constant LOD mapping for the normal map, defaults to false. |
pattern_useConstantLod Inherited | boolean | undefined | TextureMapProps | If true, override the mapping mode with constant LOD mapping for the normal map, defaults to false. |
pattern_weight Inherited | number | undefined | TextureMapProps | Weight at which to combine diffuse image and color; if undefined, defaults to 1.0 |
TextureId Inherited | string | TextureMapProps | The Id of the persistent Texture element defining the texture image. |
Defined in
- core/common/src/MaterialProps.ts Line 101
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.