ModelFeature Namespace
Function
Name | Description |
---|---|
ModelFeature.create | Create a ModelFeature of Primary with all invalid Ids. |
ModelFeature.isDefined | Returns true if any of feature 's properties differ from the defaults (invalid Ids and Primary). |
Defined in
- core/common/src/FeatureTable.ts Line 63
ModelFeature Interface
A Feature with a modelId identifying the model containing the feature, obtained from a RenderFeatureTable.
Properties
Name | Type | Description | |
---|---|---|---|
elementId | string | ||
geometryClass | GeometryClass | ||
modelId | string | ||
subCategoryId | string |
Defined in
- core/common/src/FeatureTable.ts Line 63
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.