ImageSource Class
Image data encoded and compressed in either Jpeg or Png format.
Methods
Name | Description | |
---|---|---|
constructor(data: string | Uint8Array, format: ImageSourceFormat): ImageSource | Construct a new ImageSource, which takes ownership of the Uint8Array. |
Properties
Name | Type | Description | |
---|---|---|---|
data Readonly | string | Uint8Array | The content of the image, compressed | |
format Readonly | ImageSourceFormat | The compression type. |
Defined in
- core/common/src/Image.ts Line 134
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.