overrideSubCategory Method
Deprecated in 3.x. Use override.
Specify overrides for all geometry belonging to the specified SubCategory.
overrideSubCategory(id: string, app: FeatureAppearance, replaceExisting: booleantrue): void
@note These overrides have lower priority than element and model overrides.
@note If defaultOverrides are defined, they will not apply to any geometry within this subcategory, even if the supplied appearance overrides nothing.
Parameter | Type | Description |
---|---|---|
id | string | The Id of the subcategory. |
app | FeatureAppearance | The symbology overrides. |
replaceExisting | boolean | Specifies whether to replace a pre-existing override for the same subcategory. |
Returns - void
Defined in
- core/common/src/FeatureSymbology.ts Line 743
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.