overrideModel Method
Deprecated in 3.x. Use override.
Specify overrides for all elements within the specified model.
overrideModel(id: string, app: FeatureAppearance, replaceExisting: booleantrue): void
@note These overrides take priority over all other overrides.
@note If defaultOverrides are defined, they will not apply to any element within this model, even if the supplied appearance overrides nothing.
Parameter | Type | Description |
---|---|---|
id | string | The Id of the model. |
app | FeatureAppearance | The symbology overrides. |
replaceExisting | boolean | Specifies whether to replace a pre-existing override for the same model. |
Returns - void
Defined in
- core/common/src/FeatureSymbology.ts Line 731
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.