getAppearance Method
Returns a feature's appearance overrides, or undefined if the feature is not visible. Takes Id64s as pairs of unsigned 32-bit integers for efficiency, because that is how they are stored by the PackedFeatureTable associated with each batch of graphics.
getAppearance(elemLo: number, elemHi: number, subcatLo: number, subcatHi: number, geomClass: GeometryClass, modelLo: number, modelHi: number, type: BatchType, animationNodeId: number): undefined | FeatureAppearance
@see getFeatureAppearance for an equivalent function that accepts Id64Strings instead of integer pairs.
Parameter | Type | Description |
---|---|---|
elemLo | number | |
elemHi | number | |
subcatLo | number | |
subcatHi | number | |
geomClass | GeometryClass | |
modelLo | number | |
modelHi | number | |
type | BatchType | |
animationNodeId | number |
Returns - undefined | FeatureAppearance
Defined in
- core/common/src/FeatureSymbology.ts Line 597
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.