FeatureAppearanceProvider.supplement Function
Create a provider that obtains each feature's appearance from the source, and if the feature is visible, modifies the appearance.
supplement(supplementAppearance: (appearance: FeatureAppearance) => FeatureAppearance): FeatureAppearanceProvider
Parameter | Type | Description |
---|---|---|
supplementAppearance | (appearance: FeatureAppearance) => FeatureAppearance | A function accepting the feature's base appearance and returning a supplemental appearance. |
Returns - FeatureAppearanceProvider
Defined in
- core/common/src/FeatureSymbology.ts Line 985
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.