clone Method
Create a copy of this MapLayerSettings, optionally modifying some of its properties.
clone(changedProps: Partial<ModelMapLayerProps>): ModelMapLayerSettings
@returns A MapLayerSettings with all of its properties set to match those of this
, except those explicitly defined in changedProps
.
Parameter | Type | Description |
---|---|---|
changedProps | Partial<ModelMapLayerProps> | JSON representation of the properties to change. |
Returns - ModelMapLayerSettings
A MapLayerSettings with all of its properties set to match those of this
, except those explicitly defined in changedProps
.
Defined in
- core/common/src/MapLayerSettings.ts Line 513
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.