cartographicToSpatialFromEcef Method
Convert a Cartographic to a point in this iModel's Spatial coordinates using its ecefLocation.
cartographicToSpatialFromEcef(cartographic: Cartographic, result?: Point3d): Point3d
@returns A point in this iModel's spatial coordinates
@throws IModelError if isGeoLocated is false.
@note The resultant point will only be meaningful if the ECEF coordinate is close on the earth to the iModel.
Parameter | Type | Description |
---|---|---|
cartographic | Cartographic | A cartographic location |
result | Point3d | If defined, use this for output |
Returns - Point3d
A point in this iModel's spatial coordinates
Defined in
- core/common/src/IModel.ts Line 674
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.