current
GetterReadOnly
Get the current row from the query result. The current row is the one most recently stepped-to (by step() or during iteration).
Each value from the row can be accessed by index or by name.
The format of the row is dictated by the rowFormat specified in the options
parameter of the
constructed ECSqlReader object.
current: QueryRowProxy
@see - QueryRowFormat
@note The current row is be a QueryRowProxy object. To get the row as a basic JavaScript object, call QueryRowProxy.toRow on it.
@example
const reader = iModel.createQueryReader("SELECT ECInstanceId FROM bis.Element");
while (await reader.step()) {
// Both lines below print the same value
console.log(reader.current[0]);
console.log(reader.current.ecinstanceid);
}
@returns The current row as a QueryRowProxy.
Returns - QueryRowProxy
The current row as a QueryRowProxy.
Defined in
- core/common/src/ECSqlReader.ts Line 293
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.