CreateIModelProps Interface
The properties that can be supplied when creating a new iModel.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
client Readonly | string | undefined | Client name for new iModel | |
guid Readonly | string | undefined | The GUID of new iModel. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
ecefLocation Readonly Inherited | EcefLocationProps | undefined | IModelProps | The location of the iModel in Earth Centered Earth Fixed coordinates. |
geographicCoordinateSystem Readonly Inherited | GeographicCRSProps | undefined | IModelProps | The Geographic Coordinate Reference System indicating the projection and datum used. |
globalOrigin Readonly Inherited | XYZProps | undefined | IModelProps | An offset to be applied to all spatial coordinates. |
name Readonly Inherited | string | undefined | IModelProps | The name of the iModel. |
projectExtents Readonly Inherited | Range3dProps | undefined | IModelProps | The volume of the entire project, in spatial coordinates |
rootSubject Readonly Inherited | RootSubjectProps | IModelProps | The name and description of the root subject of this iModel |
Defined in
- core/common/src/IModel.ts Line 117
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.