ModelGeometryChangesProps Interface
Compact wire format representing geometric changes to GeometricElements within a GeometricModel. A given element Id will appear in no more than one of inserted, updated, or deleted.
@see ModelGeometryChanges for a more useful representation.
Properties
Name | Type | Description | |
---|---|---|---|
deleted Readonly | string | undefined | If defined, the Ids of deleted GeometricElements. | |
guid Readonly | string | The geometry GUID of the model. | |
id Readonly | string | The Id of the model. | |
inserted Readonly | ElementIdsAndRangesProps | undefined | If defined, the Ids and ranges of newly-inserted GeometricElements. | |
range Readonly | Range3dProps | The range of the model, computed as the union of the ranges of all geometric elements within the model. | |
updated Readonly | ElementIdsAndRangesProps | undefined | If defined, the Ids and ranges of GeometricElements whose geometric properties were modified. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.