ElementIdsAndRangesProps Interface
Compact wire format representing geometric changes to a set of elements as part of a ModelGeometryChangesProps. All of the elements belong to the same model. The number of ids and ranges are guaranteed to be the same.
@see - ElementGeometryChange for a more useful representation of an individual element change.
- iterable to iterate over ElementGeometryChanges.
Properties
Name | Type | Description | |
---|---|---|---|
ids Readonly | string | The Ids of the elements, compressed and sorted in ascending order. | |
ranges Readonly | Range3dProps[] | The range of each element, indexed by the position of the corresponding element's Id in ids. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.