HorizontalCRSProps Interface
Horizontal Geographic Coordinate Reference System definition
Implemented by
Properties
Name | Type | Description | |
---|---|---|---|
datum | GeodeticDatumProps | undefined | The complete definition of the geodetic datum referred to by datumId. | |
datumId | string | undefined | The identifier of the geodetic datum as stored in the dictionary or the service database. | |
deprecated | boolean | undefined | If true then indicates the definition is deprecated. | |
description | string | undefined | Description | |
ellipsoid | GeodeticEllipsoidProps | undefined | The complete definition of the geodetic datum referred to by datumId. | |
ellipsoidId | string | undefined | The identifier of the geodetic ellipsoid as stored in the dictionary or the service database. | |
epsg | number | undefined | The EPSG code of the CRS. | |
extent | HorizontalCRSExtentProps | undefined | Extent representing the domain of application of the CRS. | |
id | string | undefined | The identifier of the horizontal CRS as stored in the dictionary or the service database | |
name | string | undefined | Used only for user-defined definitions that will typically use a GUID as id. | |
projection | ProjectionProps | undefined | Projection including projection parameters. | |
source | string | undefined | A textual description of the source of the CRS definition. | |
unit | UnitType | undefined | The text indicating the unit used. |
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.