computeFrustumContainment Method
Compute to what degree a Frustum is contained with these frustum planes.
computeFrustumContainment(box: Frustum, sphere?: BoundingSphere): FrustumPlanes.Containment
@returns the degree to which box
is contained within the clipping planes.
Parameter | Type | Description |
---|---|---|
box | Frustum | The frustum to test for containment. |
sphere | BoundingSphere | An optional spherical bounding volume fully containing box . If supplied, this can reduce the amount of computation required. |
Returns - FrustumPlanes.Containment
the degree to which box
is contained within the clipping planes.
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.