AdditionalTransform Class
Additional Transform implementation. An additional transform is a transformation that can apply to either the horizontal or vertical coordinates of a geographic CRS. The transformation is applied after the latitude/longitude have been projected thus the process is applied to the result Cartesian coordinates of the projection process.
Implements
Methods
Name | Description | |
---|---|---|
constructor(data?: AdditionalTransformProps): AdditionalTransform | ||
equals(other: AdditionalTransform): boolean | Compares two additional transforms applying a minuscule tolerance to comparing numbers. | |
toJSON(): AdditionalTransformProps | Creates a JSON from the Additional Transform definition | |
fromJSON(data: AdditionalTransformProps): AdditionalTransform Static | Creates an Additional Transform from JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
helmert2DWithZOffset Readonly | Helmert2DWithZOffset | undefined | The properties of a 2D Helmert transform with Z offset if one is defined. |
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.