ViewAttachmentLabelProps Interface

Extends

Properties

Name Type Description
viewAttachment RelatedElementProps | undefined    

Inherited properties

Name Type Inherited from Description
category Inherited string GeometricElement2dProps The id of the category for this geometric element.
classFullName Inherited string GeometricElement2dProps The full name of the ECClass for this entity, in the form "Schema:ClassName"
code Inherited CodeProps GeometricElement2dProps The Code for this element
elementGeometryBuilderParams Inherited ElementGeometryBuilderParams | undefined GeometricElement2dProps Describes how to build the element's GeometryStream, as an alternative to geom.
federationGuid Inherited string | undefined GeometricElement2dProps A FederationGuid assigned to this element.
geom Inherited GeometryStreamProps | undefined GeometricElement2dProps The geometry stream properties
id Inherited string | undefined GeometricElement2dProps The Id of the entity.
isInstanceOfEntity Readonly Inherited undefined | undefined GeometricElement2dProps A non-existent property used to discriminate between EntityProps and Entity.
jsonProperties Inherited any | undefined GeometricElement2dProps Optional json properties of this element.
model Inherited string GeometricElement2dProps The Id of the Model containing this element
parent Inherited RelatedElementProps | undefined GeometricElement2dProps The Parent of this element, if defined.
placement Inherited Placement2dProps | undefined GeometricElement2dProps The placement properties
typeDefinition Inherited RelatedElementProps | undefined GeometricElement2dProps  
userLabel Inherited string | undefined GeometricElement2dProps A user-assigned label for this element.

Defined in

Last Updated: 14 November, 2024