TextAnnotation3dProps Interface

JSON representation of a TextAnnotation3d.

Extends

Properties

Name Type Description
jsonProperties { annotation?: TextAnnotationProps } | undefined Optional json properties of this element.  

Inherited properties

Name Type Inherited from Description
category Inherited string GeometricElement3dProps The id of the category for this geometric element.
classFullName Inherited string GeometricElement3dProps The full name of the ECClass for this entity, in the form "Schema:ClassName"
code Inherited CodeProps GeometricElement3dProps The Code for this element
elementGeometryBuilderParams Inherited ElementGeometryBuilderParams | undefined GeometricElement3dProps Describes how to build the element's GeometryStream, as an alternative to geom.
federationGuid Inherited string | undefined GeometricElement3dProps A FederationGuid assigned to this element.
geom Inherited GeometryStreamProps | undefined GeometricElement3dProps The geometry stream properties
id Inherited string | undefined GeometricElement3dProps The Id of the entity.
isInstanceOfEntity Readonly Inherited undefined | undefined GeometricElement3dProps A non-existent property used to discriminate between EntityProps and Entity.
model Inherited string GeometricElement3dProps The Id of the Model containing this element
parent Inherited RelatedElementProps | undefined GeometricElement3dProps The Parent of this element, if defined.
placement Inherited Placement3dProps | undefined GeometricElement3dProps The placement properties
typeDefinition Inherited RelatedElementProps | undefined GeometricElement3dProps  
userLabel Inherited string | undefined GeometricElement3dProps A user-assigned label for this element.

Defined in

Last Updated: 14 November, 2024