PhysicalTypeProps Interface
Properties of a PhysicalType
Extends
Properties
Name | Type | Description | |
---|---|---|---|
physicalMaterial | RelatedElementProps | undefined | The PhysicalMaterial that makes up this physical type. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Inherited | string | TypeDefinitionElementProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
code Inherited | CodeProps | TypeDefinitionElementProps | The Code for this element |
federationGuid Inherited | string | undefined | TypeDefinitionElementProps | A FederationGuid assigned to this element. |
id Inherited | string | undefined | TypeDefinitionElementProps | The Id of the entity. |
isInstanceOfEntity Readonly Inherited | undefined | undefined | TypeDefinitionElementProps | A non-existent property used to discriminate between EntityProps and Entity. |
isPrivate Inherited | boolean | undefined | TypeDefinitionElementProps | |
jsonProperties Inherited | any | undefined | TypeDefinitionElementProps | Optional json properties of this element. |
model Inherited | string | TypeDefinitionElementProps | The Id of the Model containing this element |
parent Inherited | RelatedElementProps | undefined | TypeDefinitionElementProps | The Parent of this element, if defined. |
recipe Inherited | RelatedElementProps | undefined | TypeDefinitionElementProps | |
userLabel Inherited | string | undefined | TypeDefinitionElementProps | A user-assigned label for this element. |
Defined in
- core/common/src/ElementProps.ts Line 345
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.