ChannelRootAspectProps Interface
Properties of an ChannelRootAspect that identifies an Element as the root of a channel which is a subset of the overall iModel hierarchy that is independently maintained.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
owner | string | The owner of the channel |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Inherited | string | ElementAspectProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
element Inherited | RelatedElementProps | ElementAspectProps | |
id Inherited | string | undefined | ElementAspectProps | The Id of the entity. |
isInstanceOfEntity Readonly Inherited | undefined | undefined | ElementAspectProps | A non-existent property used to discriminate between EntityProps and Entity. |
jsonProperties Inherited | { T } | undefined | ElementAspectProps | Optional json properties of this Entity. |
Defined in
- core/common/src/ElementProps.ts Line 498
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.