WhiteOnWhiteReversalSettings Class
As part of a DisplayStyleSettings, controls how white-on-white reversal is applied to make white geometry more visible in the view. By default, pure white geometry is displayed as black instead if the backgroundColor is also pure white. These settings are only applied if the display style's whiteOnWhiteReversal flag is enabled.
@see whiteOnWhiteReversal to change these settings for a display style.
Methods
Name | Description | |
---|---|---|
equals(other: WhiteOnWhiteReversalSettings): boolean | Returns true if this is equivalent to other . |
|
toJSON(): undefined | WhiteOnWhiteReversalProps | Convert to JSON representation. | |
fromJSON(props?: WhiteOnWhiteReversalProps): WhiteOnWhiteReversalSettings Static | Create from JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
ignoreBackgroundColor Readonly | boolean | If true, white-on-white reversal ignores the display style's background color; otherwise, white-on-white reversal applies only |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.