SpatialClassifierFlags Class
Flags affecting how a SpatialClassifier is applied.
Methods
Name | Description | |
---|---|---|
constructor(inside: SpatialClassifierInsideDisplaySpatialClassifierInsideDisplay.ElementColor, outside: SpatialClassifierOutsideDisplaySpatialClassifierOutsideDisplay.Dimmed, isVolumeClassifier: booleanfalse): SpatialClassifierFlags | Construct new flags. | |
clone(changedProps?: Partial<SpatialClassifierFlagsProps>): SpatialClassifierFlags | Create flags indentical to these ones except for any properties explicitly specified by changedProps . |
|
equals(other: SpatialClassifierFlags): boolean | Return true if these flags are equivalent to other . |
|
equalsProps(props: SpatialClassifierFlagsProps): boolean | Return true if these flags are equivalent to props . |
|
toJSON(): SpatialClassifierFlagsProps | Convert to JSON representation. | |
fromJSON(props: SpatialClassifierFlagsProps): SpatialClassifierFlags Static | Construct from JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
inside Readonly | SpatialClassifierInsideDisplay | How geometry intersecting the classifier should be displayed. | |
isVolumeClassifier Readonly | boolean | True for volume classification; false for planar classification. | |
outside Readonly | SpatialClassifierOutsideDisplay | How geometry not intersecting the classifier should be displayed. |
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.