clone Method
Create a copy of this SolarLight, identical except in any properties explicitly specified by changedProps
, with a possible exception for timePoint.
If this.timePoint
is defined and changedProps
defines direction
but doesn't define timePoint
, the time point will only be preserved in the
copy if changesProps.direction
is equal to this.direction
.
clone(changedProps?: SolarLightProps): SolarLight
Parameter | Type | Description |
---|---|---|
changedProps | SolarLightProps |
Returns - SolarLight
Defined in
- core/common/src/LightSettings.ts Line 105
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.