SkyGradient Class
Describes how to map a two- or four-color Gradient to the interior of a sphere to produce a SkyBox.
@see gradient.
Methods
Name | Description | |
---|---|---|
clone(changedProps: SkyGradientProperties): SkyGradient | Create ea copy of this gradient, identical except for any properties explicitly specified by changedProps . |
|
equals(other: SkyGradient): boolean | Returns true if this gradient is equivalent to the supplied gradient. | |
toJSON(): SkyBoxProps | Convert to JSON representation. | |
create(props?: Partial<SkyGradientProperties>): SkyGradient Static | Create a new gradient. | |
fromJSON(props?: SkyBoxProps): SkyGradient Static | Create from JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
defaults Static Readonly | SkyGradient | Default settings for a four-color gradient. | |
groundColor Readonly | ColorDef | ||
groundExponent Readonly | number | ||
nadirColor Readonly | ColorDef | ||
skyColor Readonly | ColorDef | ||
skyExponent Readonly | number | ||
twoColor Readonly | boolean | ||
zenithColor Readonly | ColorDef |
Defined in
- core/common/src/SkyBox.ts Line 159
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.