RenderSchedule.VisibilityEntry Class
A timeline entry that controls the visibility of the associated geometry.
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: RenderSchedule.VisibilityEntryProps): RenderSchedule.VisibilityEntry | ||
compareTo(other: RenderSchedule.VisibilityEntry): number | ||
toJSON(): RenderSchedule.VisibilityEntryProps |
Inherited methods
Name | Inherited from | Description |
---|---|---|
equals(other: RenderSchedule.TimelineEntry): boolean | RenderSchedule.TimelineEntry |
Properties
Name | Type | Description | |
---|---|---|---|
value Readonly | number | The visibility of the geometry at this point on the timeline, in the range [0, 100] where 0 is completely invisible, 100 is completely visible, |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
interpolation Readonly | RenderSchedule.Interpolation | RenderSchedule.TimelineEntry | How to interpolate from this entry to the next entry in the timeline. |
time Readonly | number | RenderSchedule.TimelineEntry | The time point in seconds in the Unix Epoch. |
Defined in
- core/common/src/RenderSchedule.ts Line 215
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.