PlanProjectionSettings Class
Describes how to draw a plan projection model. A plan projection model is a GeometricModel3d whose geometry all lies in a single XY plane, wherein the Z coordinate of the plane may be arbitrary or flexible. Multiple plan projection models can be combined into one view and drawn as "layers" with relative priorities.
@see - setPlanProjectionSettings to define plan projection settings for a DisplayStyle3dState.
Methods
Name | Description | |
---|---|---|
clone(changedProps?: PlanProjectionSettingsProps): PlanProjectionSettings | Create a copy of this PlanProjectionSettings, optionally modifying some of its properties. | |
equals(other: PlanProjectionSettings): boolean | Return true if these settings are equivalent to the specified settings. | |
toJSON(): PlanProjectionSettingsProps | ||
fromJSON(props: PlanProjectionSettingsProps): undefined | PlanProjectionSettings Static |
Properties
Name | Type | Description | |
---|---|---|---|
elevation Readonly | number | undefined | See elevation | |
enforceDisplayPriority Readonly | boolean | undefined | See enforceDisplayPriority | |
overlay Readonly | boolean | See overlay | |
transparency Readonly | number | undefined | See transparency |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.