PlanarClipMaskMode Enumeration
The different modes by which a PlanarClipMaskSettings collects the geometry used to mask a model.
Members
Name | Value | Description |
---|---|---|
ExcludeElements | Indicates that masks should be produced from the geometry of all GeometricElements in a view, except for a specified set of excluded elements. View settings do not affect what is in the mask, unless subCategoryOrElementIds is undefined, in which case it behaves like Models mode. |
|
IncludeElements | Indicates that masks should be produced from the geometry of a set of GeometricElements. View settings do not affect what is in the mask, unless subCategoryOrElementIds is undefined, in which case it behaves like Models mode. |
|
IncludeSubCategories | Indicates that masks should be produced from geometry belonging to a set of subcategories. View settings do not affect what is in the mask, unless subCategoryOrElementIds is undefined, in which case it behaves like Models mode. |
|
Models | Indicates that masks should be produced from the geometry in a set of GeometricModels, regardless of what model is on or off in the view. However, things that are off from category settings or element feature overrides in the view will not be in the mask for these models. |
|
None | No masking. | |
Priority | Mask based on priority. Different types of models have different default priorities as enumerated by PlanarClipMaskPriority. For example, background maps have the lowest priority, so they are masked by all other types, while design models have the highest priority and are therefore never masked. The priority of a reality model can be overridden by priority. This is useful to allow one reality model to mask another overlapping one. Everything visible in the view creates the mask, so turning off models, categories, or elements (via fully transparent overrides) will make things not be in the mask. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.