DisplayStyleModelAppearanceProps Interface
A FeatureAppearanceProps applied to a specific model to override its appearance within the context of a DisplayStyle.
@see modelOvr.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
modelId | string | The Id of the model whose appearance is to be overridden. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
emphasized Inherited | "true" | undefined | FeatureAppearanceProps | See emphasized. |
ignoresMaterial Inherited | "true" | undefined | FeatureAppearanceProps | See ignoresMaterial. |
linePixels Inherited | LinePixels | undefined | FeatureAppearanceProps | See linePixels. |
lineRgb Inherited | "false" | RgbColorProps | FeatureAppearanceProps | See lineRgb. |
lineTransparency Inherited | number | "false" | FeatureAppearanceProps | See lineTransparency. |
nonLocatable Inherited | "true" | undefined | FeatureAppearanceProps | See nonLocatable. |
rgb Inherited | RgbColorProps | undefined | FeatureAppearanceProps | See FeatureAppearance.rgb. |
transparency Inherited | number | undefined | FeatureAppearanceProps | See transparency. |
viewDependentTransparency Inherited | "true" | undefined | FeatureAppearanceProps | See viewDependentTransparency. |
weight Inherited | number | undefined | FeatureAppearanceProps | See FeatureAppearance.weight. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.