update Method
Change selected properties of a reality model.
update(toUpdate: ContextRealityModel, updateProps: Partial<ContextRealityModelProps>): ContextRealityModel
@returns The updated reality model, identical to toUpdate
except for properties explicitly supplied by updateProps
.
@throws Error if toUpdate
is not present in the list.
Parameter | Type | Description |
---|---|---|
toUpdate | ContextRealityModel | The reality model whose properties are to be modified. |
updateProps | Partial<ContextRealityModelProps> | The properties to change. |
Returns - ContextRealityModel
The updated reality model, identical to toUpdate
except for properties explicitly supplied by updateProps
.
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.