constructor Method
Overloads | |
---|---|
constructorContextRealityModels(args) | |
constructorContextRealityModels(container, createContextRealityModel?) |
ContextRealityModels(args)
Construct a new list of reality models from its JSON representation. The list will be initialized from args.container.contextRealityModels
and that JSON representation
will be kept in sync with changes made to the list. The caller should not directly modify container.contextRealityModels
or its contents as that will cause the list
to become out of sync with the JSON representation.
ContextRealityModels(args: ContextRealityModelsArgs): ContextRealityModels
Parameter | Type | Description |
---|---|---|
args | ContextRealityModelsArgs | Specifies the container and optionally customizes how the list of models is populated. |
Returns - ContextRealityModels
ContextRealityModels(container, createContextRealityModel?)
Construct a new list of reality models from its JSON representation. The list will be initialized from container.contextRealityModels
and that JSON representation
will be kept in sync with changes made to the list. The caller should not directly modify container.contextRealityModels
or its contents as that will cause the list
to become out of sync with the JSON representation.
ContextRealityModels(container: ContextRealityModelsContainer, createContextRealityModel?: (props: ContextRealityModelProps) => ContextRealityModel): ContextRealityModels
Parameter | Type | Description |
---|---|---|
container | ContextRealityModelsContainer | The object that holds the JSON representation of the list. |
createContextRealityModel | (props: ContextRealityModelProps) => ContextRealityModel | Optional function used to instantiate each ContextRealityModel in the list. |
Returns - ContextRealityModels
Defined in
Last Updated: 13 November, 2024