create MethodStatic
Create a new CodeSpec from the specified parameters
Note: CodeSpec.id will not be valid until inserted
create(iModel: IModel, name: string, scopeType: CodeScopeSpec.Type, scopeReq?: CodeScopeSpec.ScopeRequirement): CodeSpec
@see CodeSpecs.insert
Parameter | Type | Description |
---|---|---|
iModel | IModel | |
name | string | |
scopeType | CodeScopeSpec.Type | |
scopeReq | CodeScopeSpec.ScopeRequirement |
Returns - CodeSpec
Defined in
- core/common/src/Code.ts Line 299
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.