TextRunProps Interface
JSON representation of a TextRun.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
baselineShift | BaselineShift | undefined | Whether to display content as a subscript, superscript, or normally. | |
content | string | undefined | The characters displayed by the run. | |
type Readonly | "text" | Discriminator field for the RunProps union. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
styleName Inherited | string | TextBlockComponentProps | The name of a TextStyle stored in a Workspace from which the base TextStyleSettings applied to the component originates. |
styleOverrides Inherited | TextStyleSettingsProps | undefined | TextBlockComponentProps | Deviations from the base TextStyleSettings defined by the TextStyle applied to this component. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.