TextAnnotationAnchor Interface
Describes how to compute the "anchor point" for a TextAnnotation. The anchor point is a point on or inside of the 2d bounding box enclosing the contents of the annotation's TextBlock. The annotation can be rotated and translated relative to the anchor point. The anchor point also serves as the snap point when AccuSnap is set to SnapMode.Origin. computeTransform will align the anchor point with (0, 0).
@see TextAnnotation for a description of how the anchor point is computed.
Properties
Name | Type | Description | |
---|---|---|---|
horizontal | "center" | "left" | "right" | The horizontal alignment of the anchor point. | |
vertical | "top" | "middle" | "bottom" | The vertical alignment of the anchor point. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.