PerfLogger Class
Simple performance diagnostics utility. It measures the time from construction to disposal. On disposal it logs the routine name along with the duration in milliseconds. It also logs the routine name at construction time so that nested calls can be disambiguated.
The timings are logged using the log category Performance and log severity LogLevel.INFO. Enable those, if you want to capture timings.
Implements
Methods
Name | Description | |
---|---|---|
constructor(operation: string, metaData?: LoggingMetaData): PerfLogger | ||
dispose(): void | Disposes of any resources owned by this object. |
Defined in
- core/bentley/src/Logger.ts Line 310
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.