ChangeSetStatus Enumeration
Error statuses produced by various Changeset operations, typically encountered as the errorNumber
of an IModelError.
Members
Name |
Value |
Description |
ApplyError |
|
Error applying a change set when reversing or reinstating it |
CannotMergeIntoMaster |
|
Cannot merge changes into a Master DgnDb. |
CannotMergeIntoReadonly |
|
Cannot merge changes into a Readonly DgnDb. |
CannotMergeIntoReversed |
|
Cannot merge changes into a DgnDb that has reversed change sets. |
CHANGESET_ERROR_BASE |
|
|
ChangeTrackingNotEnabled |
|
Change tracking has not been enabled. The ChangeSet API mandates this. |
CorruptedChangeStream |
|
Contents of the change stream are corrupted and does not match the ChangeSet |
CouldNotOpenDgnDb |
|
Could not open the DgnDb to merge change set |
DownloadCancelled |
|
ChangeSet(s) download was cancelled. |
FileNotFound |
|
File containing the changes to the change set is not found |
FileWriteError |
|
Error writing the contents of the change set to the backing change stream file |
HasLocalChanges |
|
Cannot perform the operation since the Db has local changes |
HasUncommittedChanges |
|
Cannot perform the operation since current transaction has uncommitted changes |
InDynamicTransaction |
|
Cannot perform the operation since system is in the middle of a dynamic transaction |
InvalidId |
|
Invalid ChangeSet Id |
InvalidVersion |
|
Invalid version of the change set |
IsCreatingChangeSet |
|
Cannot perform operation since system is in the middle of a creating a change set |
IsNotCreatingChangeSet |
|
Cannot perform operation since the system is not creating a change set |
MergePropagationError |
|
Error propagating the changes after the merge |
MergeSchemaChangesOnOpen |
|
Cannot merge changes in in an open DgnDb. Close the DgnDb, and process the operation when it is opened. |
NothingToMerge |
|
No change sets to merge |
NoTransactions |
|
No transactions are available to create a change set |
ParentMismatch |
|
Parent change set of the Db does not match the parent id of the change set |
ProcessSchemaChangesOnOpen |
|
Cannot process changes schema changes in an open DgnDb. Close the DgnDb, and process the operation when it is opened. |
ReverseOrReinstateSchemaChanges |
|
Cannot reverse or reinstate schema changes. |
SQLiteError |
|
Error performing a SQLite operation on the Db |
Success |
|
|
WrongDgnDb |
|
ChangeSet originated in a different Db |
Defined in
Last Updated: 14 November, 2024