OrderedSet<T> Class
A mutable ReadonlyOrderedSet.
Extends
Methods
Name | Description | |
---|---|---|
constructor<T>(compare: OrderedComparator<T>, clone: CloneFunction<T>shallowClone): OrderedSet<T> | Construct a new OrderedSet |
|
add(value: T): this | Add the specified element to the set. | |
clear(): void | Remove all elements from the set. | |
delete(value: T): boolean | Removes the specified element from the set. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
[iterator](): Iterator<T, any, any> Inherited | ReadonlyOrderedSet<T> | Iterate over the elements in sorted order (as opposed to Set 's iterator, which returns elements in insertion order). |
has(value: T): boolean Inherited | ReadonlyOrderedSet<T> | Returns true if value is present in the set. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_array Protected Readonly Inherited | SortedArray<T> | ReadonlyOrderedSet<T> | |
size Accessor Inherited ReadOnly | number | ReadonlyOrderedSet<T> | The number of elements in the set. |
Defined in
- core/bentley/src/OrderedSet.ts Line 47
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.