constructor Method
Construct a new IndexMap
IndexMap<T>(compare: OrderedComparator<T>, maximumSize: numberNumber.MAX_SAFE_INTEGER, clone: CloneFunction<T>shallowClone): IndexMap<T>
Parameter | Type | Description |
---|---|---|
compare | OrderedComparator<T> | The function used to compare elements within the map. |
maximumSize | number | The maximum number of elements permitted in the IndexMap. The maximum index of an element is maximumSize-1. |
clone | CloneFunction<T> | The function invoked to clone a new element for insertion into the array. The default implementation simply returns its input. |
Returns - IndexMap<T>
Defined in
- core/bentley/src/IndexMap.ts Line 43
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.