WorkspaceDbSettingsProps Interface
Specifies a resource inside a WorkspaceDb that holds a SettingsDictionary to load into settings. Settings of this type named settingsWorkspaces are automatically loaded by loadSettingsDictionary.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
priority | number | The priority to assign to the SettingsDictionary. | |
resourceName | string | The name of the resource holding the stringified JSON of the SettingsDictionary. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
accessToken Inherited | string | undefined | WorkspaceDbCloudProps | SAS token that grants access to the container. |
alias Readonly Inherited | string | undefined | WorkspaceDbCloudProps | an alias for the container. |
baseUri Readonly Inherited | string | WorkspaceDbCloudProps | The base URI for the container. |
containerId Readonly Inherited | string | WorkspaceDbCloudProps | The name of the container. |
dbName Readonly Inherited | string | undefined | WorkspaceDbCloudProps | The name of the WorkspaceDb. |
description Readonly Inherited | string | undefined | WorkspaceDbCloudProps | A user-friendly description of the container's contents. |
includePrerelease Readonly Inherited | boolean | undefined | WorkspaceDbCloudProps | If true, allow semver prerelease versions, e.g., "1.4.2-beta.0". |
isPublic Readonly Inherited | boolean | undefined | WorkspaceDbCloudProps | true if the container is public (doesn't require authorization) |
loadingHelp Readonly Inherited | string | undefined | WorkspaceDbCloudProps | A message to display to the user if problems occur while loading the container. |
lockExpireSeconds Readonly Inherited | number | undefined | WorkspaceDbCloudProps | Duration for holding write lock, in seconds. |
logId Readonly Inherited | string | undefined | WorkspaceDbCloudProps | string attached to log messages from CloudSQLite. |
prefetch Readonly Inherited | boolean | undefined | WorkspaceDbCloudProps | If true, start a prefetch operation whenever this WorkspaceDb is opened, to begin downloading pages of the database before they are needed. |
secure Readonly Inherited | boolean | undefined | WorkspaceDbCloudProps | if true, container is attached in "secure" mode (blocks are encrypted). |
storageType Readonly Inherited | "azure" | "google" | WorkspaceDbCloudProps | The type of storage provider. |
syncOnConnect Readonly Inherited | boolean | undefined | WorkspaceDbCloudProps | Whether to synchronize the container via CloudSqlite.CloudContainer.checkForChanges whenever it is connected to a CloudCache. |
tokenRefreshSeconds Readonly Inherited | number | undefined | WorkspaceDbCloudProps | number of seconds between auto-refresh of access token. |
version Readonly Inherited | string | undefined | WorkspaceDbCloudProps | The range of acceptable versions of the WorkspaceDb of the specified dbName. |
writeable Readonly Inherited | boolean | undefined | WorkspaceDbCloudProps | if true, container is allowed to request the write lock. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.