SettingsDictionary Interface

A named container that supplies values for Settings.

@see addDictionary to register a new settings dictionary.

Methods

Name Description
getSetting<T extends JSONSchemaType>(settingName: string): undefined | T Obtain a copy of the value of the setting named settingName stored in this dictionary, or undefined if no such setting exists.  

Properties

Name Type Description
props Readonly SettingsDictionaryProps Metadata describing the dictionary.  

Defined in

Last Updated: 14 November, 2024