SettingsDictionaryProps Interface

Properties of a SettingsDictionary, defining its name, the WorkspaceDb (if any) from which it originated, and its priority relative to other dictionaries.

Extends

Properties

Name Type Description
priority Readonly number Precedence value determining which setting value to use when multiple dictionaries supply values for the same SettingName.  

Inherited properties

Name Type Inherited from Description
name Readonly Inherited string SettingsDictionarySource The name of the dictionary, which must be unique within its workspaceDb, or - if workspaceDb is undefined - unique among all dictionaries not associated with any WorkspaceDb.
workspaceDb Readonly Inherited WorkspaceDb | undefined SettingsDictionarySource The WorkspaceDb from which the dictionary originated.

Defined in

Last Updated: 14 November, 2024