WorkspaceContainerProps Interface
Properties describing a WorkspaceContainer for methods like getContainerAsync.
Extends
- Optional<CloudSqlite.ContainerAccessProps, "accessToken">
Properties
Name | Type | Description | |
---|---|---|---|
description Readonly | string | undefined | A user-friendly description of the container's contents. | |
loadingHelp Readonly | string | undefined | A message to display to the user if problems occur while loading the container. | |
syncOnConnect Readonly | boolean | undefined | Whether to synchronize the container via CloudSqlite.CloudContainer.checkForChanges whenever it is connected to a CloudCache. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
accessToken Inherited | string | undefined | Optional | SAS token that grants access to the container. |
alias Readonly Inherited | string | undefined | Optional | an alias for the container. |
baseUri Readonly Inherited | string | Optional | The base URI for the container. |
containerId Readonly Inherited | string | Optional | The name of the container. |
isPublic Readonly Inherited | boolean | undefined | Optional | true if the container is public (doesn't require authorization) |
lockExpireSeconds Readonly Inherited | number | undefined | Optional | Duration for holding write lock, in seconds. |
logId Readonly Inherited | string | undefined | Optional | string attached to log messages from CloudSQLite. |
secure Readonly Inherited | boolean | undefined | Optional | if true, container is attached in "secure" mode (blocks are encrypted). |
storageType Readonly Inherited | "azure" | "google" | Optional | The type of storage provider. |
tokenRefreshSeconds Readonly Inherited | number | undefined | Optional | number of seconds between auto-refresh of access token. |
writeable Readonly Inherited | boolean | undefined | Optional | if true, container is allowed to request the write lock. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.