CloudSqlite.ContainerAccessProps Interface
Properties to access a CloudContainer.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
accessToken | string | SAS token that grants access to the container. | |
alias Readonly | string | undefined | an alias for the container. | |
lockExpireSeconds Readonly | number | undefined | Duration for holding write lock, in seconds. | |
logId Readonly | string | undefined | string attached to log messages from CloudSQLite. | |
secure Readonly | boolean | undefined | if true, container is attached in "secure" mode (blocks are encrypted). | |
tokenRefreshSeconds Readonly | number | undefined | number of seconds between auto-refresh of access token. | |
writeable Readonly | boolean | undefined | if true, container is allowed to request the write lock. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
baseUri Readonly Inherited | string | CloudSqlite.ContainerProps | The base URI for the container. |
containerId Readonly Inherited | string | CloudSqlite.ContainerProps | The name of the container. |
isPublic Readonly Inherited | boolean | undefined | CloudSqlite.ContainerProps | true if the container is public (doesn't require authorization) |
storageType Readonly Inherited | "azure" | "google" | CloudSqlite.ContainerProps | The type of storage provider. |
Defined in
- core/backend/src/CloudSqlite.ts Line 120
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.