getSetting Method
Obtain a copy of the value of the setting named settingName
stored in this dictionary, or undefined
if no such setting exists.
The returned value is always cloned using Setting.clone.
getSetting<T extends JSONSchemaType>(settingName: string): undefined | T
@note Generally, applications use methods like getString and getArray to resolve a setting value from multiple
dictionaries. Those methods - unlike this one - also validate that settingName
is of type T
as defined by its SettingSchema.
Parameter | Type | Description |
---|---|---|
settingName | string |
Returns - undefined | T
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.