SettingSchema Interface

Metadata describing a single Setting as part of a SettingGroupSchema. Every setting has a type, which can be one of the following:

  • A primitive type like string or number;
  • An object containing any number of named properties, each with their own types; or
  • An array of elements, all of the same type. This metadata is used to validate setting values against the schema, and to enable user interfaces by which users can view and modify their settings.

Extends

Properties

Name Type Description
combineArray Readonly boolean | undefined For arrays only, specifies how getArray resolves the value of the setting.  
extends Readonly string | undefined For objects and arrays only, the name of a SettingSchema that provides a base definition for this type.  
items Readonly SettingSchema | undefined For arrays only, the metadata describing every element in the array.  
properties Readonly { T } | undefined For objects only, the name and metadata of each of the object's properties.  
type Readonly JSONSchemaTypeName The name of the Setting's data type.  

Defined in

Last Updated: 14 November, 2024