insert MethodStatic
Insert an OrthographicViewDefinition
insert(iModelDb: IModelDb, definitionModelId: string, name: string, modelSelectorId: string, categorySelectorId: string, displayStyleId: string, range: Range3d, standardView: StandardViewIndexStandardViewIndex.Iso): string
@returns The Id of the newly inserted OrthographicViewDefinition element
@throws IModelError if there is an insert problem.
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | Insert into this iModel |
definitionModelId | string | Insert the new OrthographicViewDefinition into this DefinitionModel |
name | string | The name/CodeValue of the view |
modelSelectorId | string | The ModelSelector that this view should use |
categorySelectorId | string | The CategorySelector that this view should use |
displayStyleId | string | The DisplayStyle3d that this view should use |
range | Range3d | Defines the view origin and extents |
standardView | StandardViewIndex | Optionally defines the view's rotation |
Returns - string
The Id of the newly inserted OrthographicViewDefinition element
Defined in
- core/backend/src/ViewDefinition.ts Line 473
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.