insert MethodStatic

Insert a DisplayStyle2d for use by a ViewDefinition.

insert(iModelDb: IModelDb, definitionModelId: string, name: string): string

@returns The Id of the newly inserted DisplayStyle2d element.

@throws IModelError if unable to insert the element.

Parameter Type Description
iModelDb IModelDb Insert into this iModel
definitionModelId string Insert the new DisplayStyle2d into this DefinitionModel
name string The name of the DisplayStyle2d

Returns - string

The Id of the newly inserted DisplayStyle2d element.

Defined in

Last Updated: 13 November, 2024